Compatibilité des versions

Bonjour,

Dans mon dernier article nous avons écrit notre première routine en VB .Net. Nous l’avons écrite en utilisant Visual Studio 2010 et ciblé la version 2012 d’AutoCAD. Avez-vous tenté de charger le DLL dans une autre version d’AutoCAD en utilisant la command Netload? Dans la version 2011 ou 2010 vous avez sûrement eu un message indiquant que le DLL utilisait une version plus récente du «runtime». Quant à la version 2013, aucun message d’erreur n’apparait mais la commande n’est pas reconnue.

Commençons par les versions antérieures (2010 ou 2011). Ces versions d’AutoCAD utilisent la version 3.5 du «framework» .Net. Pour créer des applications pour ces versions, nous aurions pu utiliser Visual Studio 2008 qui cible par défaut cette version, mais nous pouvons tous simplement recompiler en utilisant une version antérieur du «framework».

Lire la suite